Jump to content
CJGREEN

Harsh Ride

<t></t>  

  1. 1. <t></t>



Recommended Posts

Comparing my decked E46 on budget coilovers to my friends standard MCS.


The mini is horrendously harsh. Crashes and bangs over everything. Awesome if you wanna hammer it but horrible if you want a nice drive about.


Is this the norm?


Its had 2 new recent strut top mounts also but still gets a weird rubbing style noise when turning at low speeds.


Any ideas?


James

Share this post


Link to post
Share on other sites

Is it still on run flats? There a harsh ride on them it's night and day when you change to non run flats,the only other common thing is the rear bush in the front suspension arms fail,but usually will make the car pull to one side or bang on bumps if there really shot.

Share this post


Link to post
Share on other sites

Rubbing noises when turning could be down to knackered front discs (I get this at the mo). As Lee says runflats are bad and if they're wrapping 18's then it'll be nasty

Share this post


Link to post
Share on other sites
runflats are a killer...and with the coil overs i have probably exaggerate the harshness too

Share this post


Link to post
Share on other sites

runflats are evil, and might possibly be the manifestation on beelzebub himself. Also a lot of standard alloys are very heavy too and the combined effect is a ride that is mental high and will shatter your spine into a million parts

Share this post


Link to post
Share on other sites

runflats, lowering springs, crap coilovers and all that's listed above!

Share this post


Link to post
Share on other sites

Sorry for delay. Tapatalk doesnt subscribe the topics I create on here.


Will work through the list and see whats what.


Thanks.

Share this post


Link to post
Share on other sites

sorry for venturing off topic with this but i can never see the point of using stupid apps like that!


you have a SMART PHONE, but use a DUMB app. use the web browser as its intended...Rant over lol

Share this post


Link to post
Share on other sites

Ive only had the problem on this forum. The app works fine with the other 3 I use mainly. I hate using web based pages through browser on my phone.

Share this post


Link to post
Share on other sites

4yte9uru.jpg4yte9uru.jpg"><a href=http://img.tapatalk.com/d/14/08/16/4yte9uru.jpg' alt='URL>'>


Are you swiping left to show the star ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

Guidelines